开发
API

tt.followAwemeUser

基础库 2.19.0 开始支持本方法,低版本需做兼容处理,这是一个异步方法。

调用此 API 会弹出弹框,用户可以点击按钮关注绑定的抖音号。只支持在抖音和抖音 Lite App 上使用。

使用该功能前开发者需要绑定想要关注的抖音号,具体信息请参考功能接入指引

语法

tt.followAwemeUser(options)

参数说明

options 为 object 类型,属性如下:

属性名类型默认值必填说明最低支持版本
successfunction接口调用成功后的回调函数2.19.0
failfunction接口调用失败后的回调函数2.19.0
completefunction接口调用结束后的回调函数(调用成功、失败都会执行)2.19.0

回调成功

object 类型,属性如下:

属性名类型说明最低支持版本
errMsgstring"followAwemeUser:ok"2.19.0
followedboolean返回调用此 API 之前是否已关注抖音号2.19.0

回调失败

object 类型,属性如下:

属性名类型说明最低支持版本
errMsgstring"followAwemeUser:fail " + 详细错误信息2.19.0
errNonumber错误码2.53.0

错误说明

errNoerrMsg说明最低支持版本
10301followAwemeUser:fail feature is not supported in app宿主未实现2.53.0
10601followAwemeUser:fail not login没有登录2.53.0
10502followAwemeUser:fail cancel用户取消操作2.53.0
21100followAwemeUser:fail aweme uid is null没有绑定想要跳转的抖音号2.53.0
21101followAwemeUser:fail previous API call not finished yet前面的 API 调用还没执行完2.53.0
21102followAwemeUser:fail following request failed关注抖音号请求失败2.53.0

扫码体验

请使用字节宿主APP扫码

代码示例

开发者工具中预览

tt.followAwemeUser({
  success: (res) => {
    console.log(res.followed);
  },
});

Bug & Tip

  • Tip: 使用该功能前开发者需要绑定想要关注的抖音号;
  • Tip: 没有绑定想要跳转的抖音号,会触发 fail 回调,对应的错误码是 21100 。
点击纠错
该文档是否对你的开发有所帮助?
有帮助
没帮助
该文档是否对你的开发有所帮助?
有帮助
没帮助